Volkswagen Atlas Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I bought my atlas cross sport V6 se in June 2020. After driving 5000 miles, there was an abnormal noise on the left chassis. After inspection, the sway bar link is damaged. But they told me that there are no parts and I need to wait for 2-3 weeks. Now it is the 4th week and I have not received a call. Now my left front shock absorber has also started to leak oil. What happened to Volkswagen. . .
 

·
Moderator
Joined
·
264 Posts
Welcome to the forum FredYuchen,

Sorry to read about your issues, have you tried to reach out to the dealer principals and or VW Customer Service :unsure:
 

·
Registered
Joined
·
4 Posts
I bought my atlas cross sport V6 se in June 2020. After driving 5000 miles, there was an abnormal noise on the left chassis. After inspection, the sway bar link is damaged. But they told me that there are no parts and I need to wait for 2-3 weeks. Now it is the 4th week and I have not received a call. Now my left front shock absorber has also started to leak oil. What happened to Volkswagen. . .
The sway bar links going bad and making noise at about 5000 or so miles is a known problem (they'll get worse) and they are replacing them. Since they are in demand right now I had to wait for about 4 weeks. Since being replaced all is nice and quiet now with the front end.
 

·
Registered
Joined
·
106 Posts
I bought my atlas cross sport V6 se in June 2020. After driving 5000 miles, there was an abnormal noise on the left chassis. After inspection, the sway bar link is damaged. But they told me that there are no parts and I need to wait for 2-3 weeks. Now it is the 4th week and I have not received a call. Now my left front shock absorber has also started to leak oil. What happened to Volkswagen. . .
what year and model of Atlas do you have and is the problem resolved?
 

·
Registered
Joined
·
50 Posts
I guess I was fortunate. I had my sway bar links replaced about a month ago, and they had the parts on hand. I didn't have mine changed until about 35K miles, but it was both of them, and the dreaded clunk when going over small amounts of road damage/bumps. Everything's great now.
 
1 - 5 of 5 Posts
Top