Volkswagen Atlas Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey all!! We just took our 2018 Atlas to the car wash after some bird left us some nasty surprises on the windchill today. I’ll probably kick myself doing so as it was -43* with the windchill and will be just as cold tonight. But ... it was all over the window ?. Anyway, while washing the car I noticed some rust. Showed my husband and there is rust under the rear light and then I noticed more rust specks on each side of the vehicle.

We bought our car in July 2017 and then had issues after that. Rear ended in a parking lot 6 weeks after getting it; gone to the dealership for 6 weeks to get fixed. Then winter came and the car barely started when cold (or not even that cold). This winter we bought a new battery at our cost and hope the dealership will reimburse us — we live 5 hours away from a VW. Then our coolant just disappeared ... it was checked in September and by middle December .... gone!

The rust is concerning — I’ll contact the dealership tomorrow to see what we have to do but is this a known issue for anyone? When I called them about the coolant they were like “I haven’t heard anything” but yet I read stories online. And my battery — I fought them all last winter about how crappy the factory battery was. Help!! Please ?. Alana
 

Attachments

·
Registered
Joined
·
3 Posts
Hi Alana,

I bought a used atlas two months back, I went to ski mountain where temperature was -4 Degrees Celsius, when I started the car to drive back home there was a coolant warning, I added some water and drove back and went to vw next day and they inspected in next appt and found no leakage and just topped up coolant, I'm not sure if they really checked, he asked me to come back if it happens again, it didn't happen again since a month now from the time.
also he said sometimes if there is some water vapor in that coolant system somewhere and if that escapes then it happens (I'm not sure how it escapes without any leakage issue)

I'm didn't see any rust issue.

sorry its helpful for you but just wanted to let you know that someone else also faced this coolant issue.

thanks,
Rohit
 

·
Registered
Joined
·
119 Posts
I wonder if for some reason that condensation is building up in this area, leading to more corrosion. If you are finding it elsewhere on the vehicle too however, that could suggest there were some issues with your paint application. Better to get it addressed sooner rather than later. Let us know what the dealer reports.
 
1 - 3 of 3 Posts
Top