Volkswagen Atlas Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I am a first time Volkswagen owner and first time poster to this forum, I've been a member since I bought the Atlas just over a year ago and have been doing a lot of reading.

I am experiencing a lot of issues (gremlins) with this vehicle most being electrical related, and most of these issues are not echoed in the forum. I have gone to my dealership many time with a list of issues for them to work on, but when I go to pick up the vehicle I am always told that they could not recreate the issues I mentioned so there is nothing wrong with the vehicle. I have also gone as far as calling Volkswagen Canada with my issues and complaints in regards to the dealership and the way they are handling my case, and I never get that feeling that a company is standing behind their product nor are they willing to make things better for the customer.

My current issues with the Atlas are as follows, please let me know if you have had any of these issues and how were they resolved.

  • 1 leaking sunroof....it’s been in for the TSB and has had the plastic flaps removed to promote better draining, but it still leaks during mild to heavy rain fall.
  • 2 Low coolant warning.....the dealer says this is normal for a VW and all owners should carry a jug of coolant in the vehicle for when the light comes on
  • 3 GPS randomly stop working......while driving the GPS will disappear from my display and then I’ll get "starting Navigation" with the spinning wheel until I stop the vehicle and turn it off. Dealership has replaced the brains of the audio system, but it's still occurring randomly.
  • 4 Park Pilot..... I will randomly get a message on my main display saying “ParkPilot is currently unavailable" after taking it to the dealer 3 times for this and every time they say they cannot recreate this error, I finally was able to have this issue arise while I was near the dealership. I pulled in and showed them the error, and all they can tell me is there's nothing they can do for this issue.
  • 5 USB port..... randomly while listening to music via USB drive, the music will stop and I’ll get a message "no playable files available" or "error: Device" or "No source Available"
  • 6 Security.......this has only happened 3 times in a year...but of concern to me....I would lock the vehicle and listen for the confirmation beep and watch the side mirrors fold in at the end of the day, only to wake up the next morning and find the mirrors unfolded and doors unlocked, I have checked my surveillance and seen the exact moment the mirrors unfolded....it was not a robber nor was it one of my teenage children sneaking off during the night.
  • 7. Alignment ....... the wheel alignment is off on the front of the Atlas....about 6 months in to my ownership of the vehicle, the outside edge of the brand new front tires were completely tread free. Dealership said this was normal wear and tear and would charge to resolve this issue.
  • 8.Apple Carplay...... this is the most recent issue to come up and has not been mentioned to the dealership as of yet....AppleCarPlay will randomly stop playing music and the device would have to be disconnected and reconnected in order to play music again.
Sorry for the long rant, but I had nowhere else to go and need advice before I take a loss on this and trade it for something other than a Volkswagen.
 

·
Registered
Joined
·
6 Posts
Hi fjarmash,

I also have a 2019 Execline but I am only experiencing one issue with vibrations in the wheel at certain speeds. The car still only has 1500km so I will be bringing this to the service managers attention at the first service. What dealership are you going to for these complaints? It doesn't sound like they are making an effort to resolve these considerable issues with their top of the range and top trim vehicle. I'm in the GTA and would like to avoid this dealership.
 
1 - 3 of 3 Posts
Top